Tuesday, 29 September 2015

Install Wordgrinder .60 in Linux

To me the best applications are designed to do one thing and do it well, that's the UNIX philosophy

Wordgrinder is definitely an awesome application. It's a word-processor for the terminal full of features that you just wouldn't expect. It has spell-checking, bold fonts, italics and import/export to a range of file formats. It really does stay out of your way and lets you get on with writing. I can highly recommend this great application. 

I'm using version 0.60 and I believe version 0.50 is what's in the Ubuntu repo's at the moment. So, I'm going to show you how to get it up and running, building it is very easy to do.







Firstly, we need to download the source from github

Secondly, extract the source, if you want to do it via the command line the type this command:

unzip wordgrinder-master.zip

Then we need to cd into the directory

cd wordgrinder-master

Before we start the building process, we need to install a few dependencies

sudo apt-get install libncursesw5-dev liblua5.2-dev zlib1g-dev libxft-dev lua5.2 

We then start the install process with this command

make -j

And the final command

sudo make install PREFIX=/usr

We can then start using Wordgrinder in any terminal. I prefer lxterminal, but use whatever you like.

I will be adding more tutorials on customizing the terminal colors and fonts with a shortcut you can place in the menu, so check back soon to find out how.

After upgrading the system, I noticed that the lua filesystem is getting removed for some reason. Obviously this will impact Wordgrinder, so if yours breaks too, run this command to re-install it.

sudo apt-get install lua-filesystem